7. Режим "Заметки"

При работе в режиме "Заметки" Flipbox запускает приложение Заметки. Заметки можно запустить из Главного экрана Flipbox, выбрав значок "Рисование". Также можно выбрать значок "Заметки" в Быстром меню. Если приложение "Заметки" в настоящий момент запущено, но не активно (на экране Flipbox отображается другое приложение), можно активировать его, выбрав значок "Заметки" в Быстром меню или выбрав соответствующую миниатюру в Представлении задач.
Активное приложение Заметки
В режиме "Заметки" устройство запускает приложение для написания и редактирования документов "от руки", с использованием пальца или стилуса. Писать и рисовать на экране одновременно могут два человека (поддерживается два одновременных касания поверхности экрана). Можно создать заметки "на чистом листе" или открыть существующий документ. Если открыт существующий документ, заметки "накладываются" поверх имеющегося текста и изображений. В приложении Заметки можно открыть файлы только определённого типа – внутреннего формата приложения Заметки (файл с расширением .enb). Приложение Заметки позволяет импортировать (вставлять в существующую заметку) определённые типы файлов и экспортировать созданные заметки как изображения или документы в формате pdf. Для добавления комментариев в создаваемую заметку используется набор простых инструментов для рисования. По окончании работы с документом его можно сохранить как файл во внутреннем формате приложения Заметки (enb), или экспортировать как изображение в одном из определённых форматов.

Управлять работой приложения Заметки можно с помощью команд, сгруппированных в различные меню (см. рисунок ниже).
Меню приложения Рисование

7.1 Меню действий

Меню, представленное группой значков в левом нижнем углу окна приложения, позволяет выполнять следующие действия:
Файл – отображает меню действий с файлом и настройки дисплея (см. Файл).
Закрыть – закрывает приложение. Если редактируемый в приложении файл не сохранён, Flipbox предложит сохранить его в собственном формате. Несохранённые изменения при закрытии приложения будут утеряны.
Скриншот – сохраняет скриншот активного рисунка, отображая на экране QR-код, который позволяет участникам встречи, сканировавшим его, скачать себе на устройство сохранённый скриншот всех страниц активного рисунка (см. Скриншот).
Стирание – отключает режим стирания "ладонью" (см. Ладонь). Обратите внимание!
Если значок "Стирание" активен – инструмент Ладонь НЕ будет удалять созданные рисунки. Активный значок назначает инструменту Ладонь функцию перемещения по экрану всех нарисованных объектов одновременно. Наоборот, если значок "Стирание" неактивен - инструмент Ладонь будет использоваться для удаления ("стирания") нарисованных объектов.

7.1.1 Файл

Меню Файл содержит следующие команды (см. рисунок ниже)
Меню Файл
Создать – Создаёт пустую заметку, к которой пользователь может добавить любые изображения и рисунки. То есть, в этом режиме Вы можете начать создавать заметку на чистом листе.

Открыть – Открывает заметки, сохранённые в собственном формате приложения Заметки Flipbox. Эта команда может открыть только те файлы, которые были созданы и сохранены в приложении Заметки Flipbox.

Сохранить
– Сохраняет заметку, созданную в приложении Заметки, в собственном формате Flipbox. Этот файл можно открыть только в приложении Заметки на Flipbox.

Импорт – Позволяет вставить содержимое выбранного файла в создаваемую заметку, как изображение. Возможен импорт файлов только определённых форматов: IMG, PDF, SVG.

Экспорт
– Позволяет сохранить созданную заметку как файл в одном из известных, широко используемых форматов: IMG, PDF, SVG, IWB. Получившийся файл можно открыть во многих приложениях, поддерживающих такие форматы.

Облачное хранилище – Позволяет выбрать облачное хранилище для сохранения файла. Файл будет сохранен в собственном формате приложения Заметки Flipbox.

Фон
– Позволяет выбрать цвет фона. Такой фон будет использоваться в приложении Заметки во всех режимах, кроме Рисунка.

Отправить Email – позволяет отправить эл. почтой текущую заметку полностью, включая все объекты на всех её страницах и рисунок, в собственном формате Flipbox.

Авторегулировка яркости
– включает или отключает автоматическую настройку яркости экрана Flipbox в зависимости от освещённости помещения.

7.1.2 Скриншот

Выберите команду Скриншот, коснувшись значка в Меню действий. Отобразится окно, содержащее QR-код, отсканировав который, участник встречи сможет загрузить на своё устройство сохранённую в полном объёме заметку.
QR-код для скачивания скриншота
Участник встречи должен запустить приложение Screenshare Pro на своём устройстве и сканировать отобразившийся QR-код. Далее участник должен следовать инструкциям приложения Screenshare Pro.

Внимание! Условием для успешного скачивания скриншота будет подключение скачивающего устройства к той же беспроводной сети, к которой подключён Flipbox (см. Подключение Flipbox к локальной сети).

7.2 Меню навигации

Показывает номер текущей страницы и позволяет добавить новую или открыть определённую страницу текущей Заметки.
Меню навигации
Также меню позволяет отобразить ленту миниатюр всех страниц текущей заметки. Для этого нужно коснуться нумерации страниц. Лента миниатюр отобразится над меню навигации (см. рисунок ниже).
Коснитесь миниатюры, чтобы открыть нужную страницу.

Коснитесь стрелок, чтобы отобразить на экране Flipbox следующую/предыдущую страницу.

Коснитесь значка "плюс", чтобы добавить пустую страницу к заметке.

7.3 Меню инструментов

Перечисленные ниже инструменты можно использовать для рисования на открытом в приложении документе. Для использования инструмента выберите его. При этом значок инструмента изменит цвет на голубой. Некоторые инструменты можно настроить, в этом случае в нижней части экрана отобразится меню настроек инструмента.

Чтобы начать использовать инструмент, выберите его в меню инструментов и затем коснитесь пальцем или стилусом нужной области документа. Начинайте рисовать. Закончив рисовать в одном месте, вы можете начать рисовать в другом. Выбор другого инструмента автоматически завершит создание текущего объекта.

Важно! Созданный объект становится недоступен для редактирования инструментом, с помощью которого он был создан. Для редактирования созданного объекта используйте инструмент Выбор (см. Выбор).

В меню представлены следующие инструменты:
Выбор - Используется для выбора, перемещения и редактирования объектов (см. Выбор).
Перо - Используется для рисования пальцем или стилусом. Отображает подменю для настройки толщины, текстуры и цвета линий. Подробнее см. Перо.
Ластик – Используется для "стирания" (удаления) части текущего объекта, попадающей в область действия инструмента. Подробнее см. Ластик.
Удаление – Удаляет выбранный в текущий момент объект. Если выбрано несколько объектов – будут удалены все.
Фигуры – Позволяет добавлять к текущему документу готовые двух- и трёхмерные геометрические фигуры. Подробнее см. Фигуры
Ладонь – в зависимости от выбранной функции Ладонь удалит выбранные или переместит на холсте все существующие объекты.
Рисунок – позволяет создать рисунок, не входящий в содержимое ни одной страницы. Использует способы рисования, схожие с доступными для инструмента Перо (см. Рисунок)
Отмена – Отменяет последнее действие. Каждое нажатие отменяет одно завершённое действие. Количество отменяемых действий (шагов) не ограничено. Подробнее см. Отмена / Возврат.
Возврат – Восстанавливает отменённое командой Отмена действие. Каждое нажатие восстанавливает результат одной команды (одного шага) Отмена. Количество восстанавливаемых шагов не ограничено. Подробнее см. Отмена / Возврат.

7.3.1 Выбор

Инструмент Выбор позволяет выбрать на активном рисунке отдельный нарисованный объект (линию или фигуру) или несколько объектов. С выбранными объектами можно производить следующие действия:

  • Перемещать;
  • Редактировать, изменяя форму и цвет.
Внимание! Вы можете редактировать объекты, созданные с помощью разных инструментов, только с помощью инструмента Выбор.

Чтобы выбрать отдельный объект

Выбрать отдельный объект можно, прикоснувшись к любой его части – контур объекта на экране Flipbox будет подсвечен и выделен направляющими (см. рисунок ниже).
Выбран один объект – "Куб". Объект голубого цвета "Окружность" не включён в это выделение.
На рисунке выше выбрана трёхмерная фигура – куб. Контур этого объекта подсвечен и видны опорные точки области выбора. Зажимая и двигая опорные точки, можно менять размер и форму объекта. Можно также быстро изменить цвет объекта, используя палитру из четырёх цветов.

Если затем вы прикоснётесь к другому объекту, выделение с первого объекта будет снято, и будет выделен только тот объект, которого вы коснулись в последний раз.

Выделение со всех объектов можно снять, коснувшись экрана в области, свободной от объектов.

Чтобы выбрать несколько объектов

  • Коснитесь и удерживайте зажатым первый объект, а затем последовательно прикасайтесь к другим объектам, которые вы хотите добавить к выделению, или
  • Снимите все текущие выделения, коснувшись экрана в любом свободном от нарисованных линий месте, а затем создайте прямоугольное выделение, проведя наискосок от левого верхнего угла воображаемой прямоугольной области к его правому нижнему углу. Все объекты, полностью попавшие в эту прямоугольную область, будут выделены.

Чтобы переместить выбранные объекты

Выберите один или несколько объектов.

Коснитесь любого из выбранных объектов, и, удерживая его зажатым, перетяните на желаемое место.

Чтобы снять любое выделение

Коснитесь экрана в любом месте за пределами нарисованных объектов. Признаки выделения будут сняты.

Чтобы отредактировать выбранный объект, изменив его форму

Коснитесь нужного объекта или создайте выделение, включающее несколько объектов.

Когда выделение будет создано, зажмите любую опорную точку области выделения и перемещайте её. Вы будете видеть, как изменяются размер и форма выбранного объекта (или нескольких выбранных объектов). Подняв палец от экрана, вы зафиксируете новые размер и форму объекта.

7.3.2 Перо

Инструмент Перо позволяет одновременно рисовать на доске пальцем и двумя стилусами. То есть, доски одновременно может касаться палец и два стилуса. Настройки линий, создаваемых каждым стилусом, индивидуальны – для каждого отдельно можно настроить толщину линий, их цвет и текстуру. Настройки тонкого стилуса используются при рисовании пальцем.

Чтобы настроить линию, создаваемую инструментом Перо

1. Коснитесь значка Перо в меню инструментов. Коснитесь значка Перо повторно –отобразится меню настройки инструмента Перо.
2. В левом верхнем углу меню два значка с изображением стилуса дают возможность выбрать настройки отдельно для узкого и широкого стилуса. Настройки узкого стилуса (первый значок) используются по умолчанию и будут применяться при рисовании на экране пальцем. Сразу под значками стилусов находится ползунок – он расширяет рисуемую линию (сдвинуть ползунок вправо) или сужает её (сдвинуть влево).
3. Ниже ползунка изображены инструменты – выбирая инструмент, вы выбираете текстуру линии:
a. Карандаш - однородная, с четкими краями;
b. Средняя кисть - разной интенсивности, с размытыми краями;
c. Тонкая кисть – неоднородная, с немного размытыми краями;
d. Тонкий маркер - однородная, с немного размытыми краями.
4. Справа от ползунка находятся две палитры – на левой вы можете выбрать цвет из набора предопределённых или использовать оттеночную палитру справа.
5. Коснитесь значка с крестиком в верхней части меню, чтобы закрыть это меню.
Меню настройки инструмента Перо

7.3.3 Рисунок

Инструмент Рисунок позволяет создать отдельный рисунок, не включённый ни в одну страницу заметки.

Рисуемая линия будет закончена в тот момент, когда вы поднимете палец или стилус от экрана.

Чтобы настроить создаваемую в режиме инструмента Рисунок линию

1. Выберите значок "Рисунок" в Меню инструментов. Отобразится меню инструмента Рисунок (см. рисунок ниже)
Меню настройки инструмента Рисунок
2. Ползунок в левом верхнем углу меню Рисунок расширяет рисуемую линию (сдвинуть ползунок вправо) или сужает её (сдвинуть влево). Ниже ползунка изображены инструменты – выбирая инструмент, вы выбираете текстуру линии:
a. Карандаш - однородная, с четкими краями;
b. Тонкая кисть – неоднородная, с немного размытыми краями;
c. Широкая кисть - разной интенсивности, с размытыми краями.
3. Вы можете выбрать ластик – этот инструмент не рисует, а "стирает" нарисованное (оставляя нетронутым изображение, поверх которого вы рисуете). Линия, очищаемая ластиком, настраивается так же, как и линии карандаша, пера и кисти.
4. Справа от ползунка находится палитра – вы можете выбрать цвет из набора предопределённых. Выбранный цвет отобразится в центральном круге цветового колеса (см. следующий шаг).
5. Цветовое колесо, расположенное справа от ползунка и инструментов для рисования, можно использовать для получения оттенка выбранного цвета, двигая ползунок по кругу.
6. Пипетка, отображённая справа от цветового колеса, позволяет выбрать желаемый цвет, указав на участок изображения, отображённого на экране.
7. Нажмите на значок Треугольник в правом верхнем углу, чтобы свернуть меню Палитра.

В левом нижнем углу экрана расположено Меню действий инструмента Рисунок (см. рисунок ниже).
Меню действий инструмента Рисунок
Коснитесь значка со стрелкой, направленной вверх, чтобы вернуться в приложение Заметки.

Внимание! Закрытие инструмента Рисунок не требует сохранения созданных этим инструментом рисунков. Рисунки, созданные инструментом Рисунок, сохраняются только вместе с основным документом – заметкой.

Коснитесь значка с дискетой, чтобы сохранить все страницы, созданные инструментом Рисунок.

Коснитесь значка с обратной стрелкой, чтобы отменить последнее действие.

В правом нижнем углу экрана расположено Меню навигации инструмента Рисунок (см. рисунок ниже).
Меню навигации по страницам Рисунка

7.3.4 Ластик

Инструмент Ластик позволяет "стереть" (удалить) нарисованные объекты, попадающие в рабочую область Ластика. Рабочей областью Ластика считается создаваемое им выделение. Перемещая Ластик без отрыва пальца от экрана, перечеркните создаваемой им линией части всех объектов, которые вы хотите удалить.

Удаление ("стирание") одного объекта

1. Выберите значок Ластик в меню Инструменты.
2. Проведите стилусом или пальцем по экрану, "перечеркнув" хотя бы одну линию нарисованного объекта. Объект будет выделен полностью и будет удалён сразу же, как только вы снимете палец с экрана.
Выделение одного объекта перечёркиванием линии

Удаление ("стирание") нескольких объектов одновременно

1. Выберите значок Ластик в меню Инструменты.
2. Проведите, не отрывая, стилусом или пальцем по экрану и перечеркните создаваемой им линией части всех объектов, которые вы хотите удалить. Все объекты, перечёркнутые этой линией, будут выделены полностью и будут удалены сразу же, как только вы снимете палец с экрана.
Выделение одного объекта перечёркиванием линии

7.3.5 Удаление

Используя инструмент Удаление, вы сможете быстро очистить страницу, удалив сразу все нарисованные на ней объекты.

Быстрая очистка одной страницы Заметок

1. Выберите значок Удаление в меню Инструменты.
2. Все объекты, отображённые на текущей странице, будут удалены. Страница будет пустой.

7.3.6 Фигуры

Вы можете добавлять к рисунку готовые двух- и трёхмерные фигуры, выбирая их в меню инструмента Фигуры.

Чтобы добавить к рисунку готовую фигуру

1. Выберите значок Фигуры в меню Инструменты.
2. После этого выбора Flipbox даст вам возможность рисовать фигуру по умолчанию, это будет последняя выбранная фигура, если вы уже пользовались инструментом Фигуры после включения Flipbox.
3. Если вы не пользовались инструментом Фигуры в течение рабочей сессии, или хотите выбрать новую фигуру, коснитесь значка Фигуры повторно. Отобразится меню инструмента Фигуры (см. картинку ниже).
Меню инструмента Фигуры – двухмерные объекты
Чтобы выбрать другой тип фигур (на приведённой иллюстрации можно выбрать трёхмерные объекты – 3D – вместо текущих двухмерных – 2D), коснитесь вкладки 3D в верхней части меню (см. картинку ниже).
Меню инструмента Фигуры – двухмерные объекты. Выбрана фигура Куб.
4. Чтобы нарисовать на экране фигуру – выберите её в меню инструмента. Например, на рисунке выше выбрана и уже нарисована фигура Куб.
5. Выберите цвет, которым будет отображена рисуемая фигура – коснитесь нужного квадрата из набора предопределённых цветов в правой части меню инструмента. Выбранный цвет будет отмечен значком.
6. Чтобы нарисовать выбранную фигуру, коснитесь экрана в точке, соответствующей левому верхнему углу воображаемой рамки, содержащей эту фигуру, и тяните рамку наискосок к правому нижнему углу. Вы будете видеть, как фигура меняет размер. Не отнимая палец от экрана, регулируйте размер фигуры. Когда вы отнимете палец, фигура будет создана.

7.3.7 Ладонь

Назначение инструмента Ладонь меняется в зависимости от того, в каком положении находится переключатель "Стирание ладонью" в Меню действий.
- значок в неактивном состоянии назначает инструменту Ладонь функцию стирания рисунка (см. Меню действий)
- значок в активном состоянии назначает инструменту Ладонь функцию перемещения всех нарисованных объектов одновременно (см. Меню действий)

Чтобы стереть нарисованные линии на активном рисунке инструментом Ладонь

1. Переведите значок Отключить стирание в Меню действий приложения Заметки в
неактивное состояние - , коснувшись его.
2. Выберите инструмент Ладонь в Меню инструментов.
3. Прижмите к экрану ладонь, или только её часть, и не поднимайте её от экрана. Спустя одну-две секунды под ладонью отобразится прямоугольная область, символизирующая губку для стирания (см. рисунок ниже).
Использование инструмента Ладонь в режиме стирания рисунка
Площадь рабочей области такой "губки" зависит от площади контактирующей с экраном ладони. Например, сжав ладонь в кулак, можно вдвое уменьшить стираемую область.

4. Не поднимая ладонь от экрана, ведите её в нужном направлении, "стирая" нарисованные линии. Стирание будет прекращено, когда вы поднимете ладонь от экрана.
5. Чтобы начать стирание снова, прижмите ладонь к экрану и подождите, пока не отобразится прямоугольная область, обозначающая готовность к началу стирания (см. рисунок выше).

7.3.8 Отмена / Возврат

Используя команду Отмена – значок в Меню инструментов – вы можете последовательно отменять выполненные действия, начиная с самого последнего.

Команда Возврат – значок в Меню инструментов – позволяет восстановить результат последнего отменённого действия.

Будьте внимательны, пользуясь данным командами! Пользователю недоступен список выполненных действий, поэтому, если вы не помните точно, в каком порядке вы производили действия, отменяйте их не спеша, внимательно изучая полученный результат. Вы всегда можете выполнить противоположную команду, Возврат, и восстановить результат отменённого действия, но если вы нарисуете на странице заметок новый объект, цепочка действий, доступных для отмены и восстановления, будет прервана и начнётся заново с последнего добавленного на страницу объекта.